Communication Error - Random Drop Outs

We currently have a number of users reporting intermittent and random drop outs on the Zscaler client connector app.

Users may experience these dropouts anywhere between 0 up to ~7 times a day
Dropouts tend to last for a few seconds up to a few minutes
The Zscaler client application will show a “Connection Error” during the time of dropouts.
People will often lose connection to MS outlook, MS teams etc. Any web based apps.
We have a 50/50 spilt of Windows and Mac users - It only appears to be affecting windows users. Apple mac users appear not to be affected.
All our users are working remotely - from their home networks
The issue currently cannot be replicated on demand. Only happens at random intervals.
App is configured to fail open - but still get connection loss with web not being accessible.

We are seeing this from the debug logs

  • 2022-12-21 04:30:47.425312(+1100)[11212:4656] DBG incrementSMEFailureCount: Incremented SME failure count: 1
  • 2022-12-21 04:30:47.425312(+1100)[11212:4656] INF Changing ZIA state from: ON to SERVER_DOWN_ERROR
  • 2022-12-21 04:30:47.425312(+1100)[11212:4656] WAR ZPHM Bad health using ping

We have a escalated support case open with zscaler - but has remained unfruitful so far. All we keep getting from support based on log and packet capture support is there are network connection issues on our end.

But we feel this doesn’t currently add up - given the following:

-  It is happening to users working remotely on their various home networks. They are not connected to a central network (we are 100% cloud based, users do not VPN into corporate network)
-  It is only affecting windows users. Not mac users.
- Drop outs cease from happening when Zscaler client app is turned off.
- It appears that non web based traffic (such as SSH connections) are not affected during dropouts

We have tried a number of configuration changes to our app + forwarding profile and pac file based on zscaler’s recommendation but still no resolution.

We have tried with various app version - currently testing the latest

However given this has been going for month, and impacting a number of users - looking to see if anyone else has had similar issues, or suggestions.

1 Like

Any particular region impacted or globally?

1 Like

We have been seeing some of the same issue(s)/behavior(s) as well. Started googling and came across this post - and was hoping there was a resolution posted.

Do your windows clients have intel wifi adapters? We found the background scanning would knock our ztunnels offline periodically. We set BgScanGlobalBlocking = 1 on all our clients. This helped with the issue. Recently we have been getting poor zen selection though. The extra latency to the zen has caused some of these issues to reappear when they had mostly been resolved with the intel setting change.

Thanks! We do have Intel Wi-Fi adapters, but I’m not sure how much that’s a factor for us. I reached across the aisle to our Desktop Support team (who would manage that type of config) and they pointed me here: Solved: Global BG Scan blocking - Setting missing - Intel Communities

Guess Intel changed that several months ago. I’ll keep digging, but definitely appreciated that insight.