Downloading Issue through Zscaler GRE tunnel

,

Hi everyone
i have a very strange issue.
When i am downloading a large file over the GRE-Tunnel, the downloading gets stalled (the download looks dead but it wasn’t cancelled).
i changed the MSS size to 1400 bytes, no bandwidth or SSL polices in place.
all policies were disabled and we didn’t get a working result.
the behavior becomes normal when the download is done directly without zscaler.
what should i test or troubleshoot to solve this issue?

Does the download stall at the end or randomly?
If at the end - malware protection, advanced thread protection, sandbox etc. checked?

Hello Thomas,

It occurred randomly
We already checked all policies

Hi,
what do you see in the weblogs? Is there a high latency (server trans time) etc. and how do send/received bytes look like? There might be a limited view in the tunnel logs, too. Sent/received bytes or packets will only help, if there is no other traffic on your GRE tunnel.

Have you tried to download the file as road warrior, preferably with Zscaler client connector, but “pac-only” should also be tried?
If SSL Inspection is disabled, Zscaler will anyway not be able to apply “advanced policies”.
Finally, you can add the URL to the security exception list which will guarantee that no policies are applied

How does the download look in a wireshark capture? I have heard (in a not Zscaler context) that proxies sometimes send fake download information to the browser, so they can check the file in the background. In wireshark you can see the exact amount of bytes.

Last but not least you can try to use your backup GRE (or configure a different ZEN). I have also seen websites that do not like particular ZEN nodes. So for testing I would try to connect to a complete different region. Like Tokio ZEN if you are in Europe or US.

Best regards
Andreas