"Driver Error"- Off trusted network

FAcing issue with Zscaler app for windows
After login into account it showing “Driver Error”- Off trusted network.

Please help to resolve it

Hi @Siddhartha, welcome to Zscaler community.

You can fond this error condition and resolution path documented as follows:


In the More window, click Repair App . This option is available under the Troubleshoot menu.
To learn more, contact Zscaler Support.

Many thanks,
@skottieb :slight_smile:

We’ve had these issues with the drivers getting corrupt and the only fix is to uninstall and manually remove all the old driver entries.

@Ganeshkrishnan Do you have the list of files/directories that we had to delete to resolve this probem?

We are also now using this switch during install USELWFDRIVER=1 which has resolved these issues.


Dear skottieb,

Thanks a lot for your suggestion, although I tried the troubleshoot process mentioned here, but still not resolve.
Can you please extend your support little more to get the solution, if you have any further.

Thanks in advance.

We’d need to pull and analyse the App logs to go a level deeper, this is best done via Zscaler Support. Do you have a case open?

delete the folder C:\WINDOWS\System32\DriverStore\FileRepository\zapprd.inf_amd64_ad82295782edfdd2

this have to be done with high priviledges. This worked for me


Unable to delete this file, stating " you need permission from system to make changes to this folder"

like i said you need high priviledges. take ownership and get full access to the folder. delete the folder and reboot the workstation. this solution was given to me by zscaler support and it worked for me.


We faced similar issue and fixed it by following below steps

Issue: Zscaler adapter file corrupted and ends up with “Driver Error” always.


  1. Uninstall Zscaler app from the machine. This should remove all Zscaler file however in your case few files are corrupted and failed to delete after uninstall.

  2. Delete the below folders in the path (need admin privilege)

Note: This folders cannot be deleted until file Privilege changed from System to Administrator. You need to change the file privilege and then try deleting.

Ganesh Krishnan


Yes. You can change the file permission from System to Administrator. Then try delete the file.

Ganesh krishnan

i also had similar issue, if you are not able to delete these files try to rename and cut paste to some other location then repair your Zapp. in my case it worked.

I have the same issue. I have tried to rename the file or delete it. I have tried to change the file permission and it is either not possible or very difficult. I am using the program to access my PC at work. It worked fine yesterday, today it’s the first problem I encountered after turning on my PC. I can’t believe Zscaler puts out software that behaves likes. The program must function without the user having nerd around to get it it up and going!

If nothing this works ,. try to install Iobit Unlocker.You can to uninstall anything .

The Install Zapp along with the ‘reinstallDriver’ flag enabled ‘–reinstallDriver 1’ is key to success.

1 Like

Hi Gordon/Ganesh,
I had to manually remove the zapp files manually earlier whenever I have troubleshoot the driver error issue
Do you have more info on using USELWFDRIVER=1 install, like where can I include it to resolve the driver issue permanently ?


Anyone else having their users with the same driver error but on Mac?