External browsing fails in IE but works in Chrome

zia

(GaryS) #1

We have a strange issue where external browsing fails for all sites in IE11 or Edge, but works fine in Chrome.

Our PAC file is hosted in the Zscaler cloud, the PAC file is the same for all our browsers. It is applied via GPO and the browser settings are showing the correct URL for the PAC file.

We can hit the PAC file URL and download it in IE and Chrome, so it appears that the browsers can get to the PAC file, Chrome can utilise it but IE cannot.

Anyone experienced a similar issue? Or any insight into differences in how IE and Chrome utilise the PAC file?


(Scott Bullock) #2

Hi Gary,

I personally can’t say I’ve seen this before, it sounds like something it’s conflicting the built in browsers.

Do you have a ticket open? They will be able to assist you in pulling advanced diagnostics and helping bottoms out the issue.

Please do share any interesting details when you find a fix.

Cheers,

Scott-


(GaryS) #3

Hi Scott,

Thanks for your response. Yes, we’ve opened a ticket with the support team.

It’s a really odd issue, as it had previously been working. My understanding is that Chrome gets it browser settings including PAC file URL from the system settings, same as IE. So can’t figure out why one browser works and IE and Edge on the same machine fail.

Hoping someone has some ideas :slight_smile:

Cheers


(Thomas Quinlan) #4

The only thing that strikes me as particularly different between the two is the concept of security zones in Edge(/IE). Perhaps something shifted into a more restrictive security zone? It would explain why it worked previously but doesn’t now, and why Chrome works.


(GaryS) #5

Thanks for your suggestion Thomas.

We’ve actually found the root cause, the problem was a rogue comma in our PAC file. We had initially looked at changes to the PAC file in the event of a syntax problem, but the fact it worked via Chrome and Firefox threw us as we expected if the syntax was an issue, it would fail in all browsers. Apparently IE is more fussy about this particular syntax than the other browsers.

Also, the PAC verify feature in the Zscaler admin portal also didn’t pick up the syntax error, so we activated the change. A 3rd party verification site helped us find the problem.

Thanks.