Gmail Attachments on iPhone: No Connection

ssl

(Ilya) #1

In our organization, we are only allowing our company domain login access for Gmail (gsuite customer). On the Mac, everything works as intended. On iPhones, through the Gmail App, attachments are not working. When trying to open attachments (pdf, excel, word) it gives a black screen with no connection message at the bottom. We tried bypassing a few urls in the PAC file but with no success. Is anyone using the same setup or have a way to troubleshoot this? I’ve tried Wireshark and Fiddler with no success. I’ve read it could be an issue due to SSL pinning, but others are saying as long as we can identify URL we should good.


(David Creedy) #2

It could be SSL pinning yes. It could also potentially be that the URLs used to download content from the mobile app are different to the desktop, and that you would need to bypass these URLs also.

It might be worth raising a ticket and attaching some logs, we might be able to see if there is trouble connecting there or not.


(Ilya) #3

Thanks David.

After working with support, we set mail.google.com to SSL bypass. This worked and complied with our needs because accounts.google.com is the URL that validates which domains can log into Gmail.