Initial login to Azure VDI gets struck for few minutes with ZCC (Tunnel 2.0)

A customer has VDIs in Azure environment. They would like to have ZCC clients on those VDIs for both ZIA and ZPA. With Zscaler Internet enabled they are running into an issue during initial login to the VDI.
These are Azure Virtual Desktop, running Windows 10 single session persistent VDIs.
Issue is:
VDI initiates the launch process and stuck at welcome screen for few minutes, then it gives a reconnecting message and tries to continue login. I believe during this time ZCC tries to login and that is when we see reconnecting message.
Found a community discussion on the topic: Azure WVD and ZIA - #3 by andy11. It talks about adding WVD ranges to bypass using tunnel 2.0 bypass in app profile. The article talks about WVD IP range of approx. 288 IPs. But there is no reference to where those Ips are listed. We also tried contacting Microsoft but they say there is no fixed range of IPs.
Has anyone worked on Azure VDI deployment before? Any recommendations? (

Hi Raj,

We have exactly the same issue.
This JSON might be what you are looking for but I havent added all the IP’s yet.
Download Azure IP Ranges and Service Tags – Public Cloud from Official Microsoft Download Center

We are going to use Cloud Connectors for one use-case but the other requires ZCC.
Please share any findings


Thanks @G-Man8 , the json file has more than 50K IPs :grinning: I will try adding them region-wise and see if that makes any difference.