Private Access not connecting

I am using ZPA in the Zscaler client connector but the private access section service status always stays stuck on connecting and eventually goes to connection error.
I need to connect to remote desktop for my work which isn’t possible without connecting via zscaler
Strangely this behavior is with a better vodafone network connection 30+ Mbps
And it immediately connects with a slower JIO connection 5+ Mbps but it’s of no use as I can’t work remotely with that slow speed

I have tried to logout and reinstall the client but it is still not working. Does anyone have any suggestions?

Walter,

This is an interesting problem. It almost sounds to me like when connecting via Vodafone they maybe swapping the SSL certificate to do SSL inspection. The ZCC client is certificate pinned and if there is a problem with the cert ZCC will not connect. Do you have any type of advanced security enabled with Vodafone?

I have

Todd Harcourt

Not that I know of.
Is there a way to check?
I simply use Vodafone & JIO mobile networks for my internet usage
Both networks are in roaming.