Script Error Popups in ZApp During Login when Using Google SAML

OS: Windows 10

We’re getting IE Script Debug popups during the initial login to ZApp after deploying it to users.

Users have to keep clicking “Yes” on several of these popup messages in order to login to ZApp with their Google credentials. Some resources on the Google login also fail to load making it more difficult to login with 2FA.

Just wondering if anyone else has encountered this issue and what the solution was. We have tried adding ssl.gstatic.com to IE’s trusted sites list to no avail. ZScaler Support advised that it’s an IE caching issue but clearing the cache & temp internet files doesn’t seem to help. I have also tried disabling Scipt Debugging in the IE settings.

HI, Oskard787 we are also experiencing this issue. Did you get any further with troubleshooting? What version of the client are you running and patch / feature level of Windows 10?

It looks like it was caused by us trying to bypass accounts.google.com in the ZApp PAC files - once we took that out it seems fine. Are yall trying to do the same?

2 Likes

Hi Oskard787, Fantastic! We have also got accounts.google.com bypassed in our PAC file and tested by removing the PAC and it worked flawlessly. Now to try and figure out a solution because we need accounts.google.com bypassed.

Thanks again!

Hello, i experienced this issue however with Azure-AD integration. What helped me is adding MS domains in trust websites under Internet Options in Windows 10.

Internet Options > Security Tab

  1. https://*.microsoft-online-p.com
  2. https://*.msfauth.net

You might want to go in the same direction just for google identity

1 Like