SSL inspection tracking


I recently joined an new org which uses zscaler proxy. I am Software Engineer, trying to set my development environment in Docker (using Laptop with windows 10 ).

I am hitting this error on docker build. I researched on google. zscaler community and learnt that I need to explicitly copy pem (zscaler root) to container and update ca-certificates. I tried this approach, still same error. I tried few other things as well. Nothing helped.

For [SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed: unable to get local issuer certificate (_ssl.c:1123)‘))’: /conda-forge/linux-64/repodata.json

I suspect Zscaler inspect the ssl request from container and blocking this request for some reason.

One of my team lead (who is with org for more than 5 years) - can able to create a build successfully in Docker in Windows Laptop.

Question: How to find out if zscaler blocking SSL traffic, if so it should be same for everyone. How do I compare policies between two machines and then reach out to corporate z scaler admin team for additional help.

Please throw some light on this


Hello @Chris_Louie - Can you help me on this?

Hi Lakshmanan,
Please take a look at this article for importing the Zscaler root certificate in Docker:

Warm Regards,

1 Like