Stop ZCC via admin command-line


is there a way to stop a ZCC in login state (no user logged in) via an admin commandline ?

I can kill all ZSA processes via:
c:> taskkill /IM ZSA* /f

But after doing this the Login popup comes up again and processes restart.

Thanks Tom

Hi Tom - I’m not aware of a method to do this. It sounds like the task restart is working as designed given ZCC is a security agent and in order to support the enforcement option, it’s important not to have methods to disable it beyond the password-protected disable/logout and stop from the ZCC interface.

Do you have an example of a use case that would involve stopping the ZSA process from the command line?

Hi Mark,

we rolled out ZCC to our clients with SAML SSO for login.
But when our software maintenance is running for client updates we use a local Windows user. The software deployment automatically logs on with this user and during software update ZCC pops up because SAML SSO is not working for this local user account (only AD accounts). So we want to disable ZCC during this use case because the user sometimes thinks there is something wrong with the updates.

Regards Thomas

That makes more sense now Tom. You may consider bypassing the URL of the software maintenance so it doesn’t go through ZCC in order to avoid the message, but other than changing the whole update process to use the SAML account instead of the local one, I don’t have any other suggestions off the top of my head. Perhaps I can think about it some more and provide additional suggestions to resolve the issue if I come up with any.

Actually what we would need is executing the “Exit” function from the right-click Zscaler Icon.

Thanks Thomas