While connecting from home to my router, zscaler client breaks internet connection

While connecting from home to my router, Zscaler client breaks internet connection. All devices will be disconnected from my home router. Need to reboot my router again. New router has been provided by my ISP and set up but it still existing. No problems to connect from the office or any other WiFi or Hotspot. I got a new laptop from my company.
There is another employee who is experiencing the same problem as me. We both got the new laptop and have been having this problem connecting to our home router. Both with the same provider - both on a fibre network - both experiencing the same problem: after the initial connection to our home router, the router went into hibernation after a few seconds. All connected devices (mobile phones, tablets, TV, etc.) could no longer connect to the router. A complete reboot was required. After that, they all worked again - except for our company computers, which were connected to the Zscaler. Affected by this problem were only our company laptops that have the VPN Zscaler on it. Even by turning off the Zscaler, the router does not allow all of us to reconnect to that specific router-address anymore. Since we’ve been using the Lenovo, the connection has gone completely down. When we connect on other external routers, in the office, in hotels, in hotspots, we no longer have this problem. It is the combination of the new Lenovo - Zscaler - private fibre router (we have the same ISP) that is breaking the system. The ISP engineers have tried everything, including sending us a new router, but the problem persists.
Our internal IT Department are sending us back and forth between the global teams and the local IT department and even back to our private ISP provider. Until today, no one has been able to help us.
I have been working on my hotspot from home for 4 weeks. Need immediate support! Thanks

Whether both ZIA and ZPA is enabled?
Are you facing issue when connect only ZIA ? or only ZPA?
If the connection is working without any issues with ZPA disabled, then the issue might be at app segmentation configuration at Zscaler ZPA portal and private IPs used on your routers. In this case you can request you ISP to change the router IPs(you home network with private IP which is not part of your corporate network).

Hi Ramesh, thanks for your feedback.
As this is a company laptop, we are not allowed to disable the ZIA one. Only our admins can do that. But even when I disable the ZPA, it doesn’t work. The first attempt works for a few seconds and then everything crashes again. Any devices connected to the router at the time will not be able to reconnect. We need to reboot the whole router, and only non-company devices will be able to connect to it.