Z-app prevents clicking, file name change and other basic computer behaviors

Hello! Everyone!

I am one of Zscaler app users.
Thank you for your proxy!

Do you have problem with ZApp?
I can not move scroll bar, change file name, select multiple files or anything others to use good computer function!
When Z-App is turned off, all clear, no problem.

Do someone have any hints? Any setting and Z-App have conflict?

Best Regard
Ngyen

Hi Ngyen,

One of the possible problems is that Zapp is conflicting with IE settings GPO, due to the GPO doesn’t allow the user to change the proxy settings.
Please do the following:
1 - Exit Zapp.
2 - Open IE setttings and check if you can change the Proxy settings as normal user.
If not, this is the problem. Zapp “acts” as a user changing the IE Proxy settings. If this is blocked by GPO, the computers freeze like you describe, because Zapp is consuming all resources trying to set the proxy again and again.
The solution is to correct the GPO to allow the user to change proxy settings.
Best regards
Adrian Larsen
Maidenhead Bridge.

1 Like

We found the possible cause of such an issue.

  1. [Windows] + S
  2. search “gpedit.msc”
  3. Computer Configuration > Administrative Templates > Windows Components
  4. Client the File named “Internet Explore”
    If the item “Make proxy settings per-machine (rather than per-user)” is enabled, the issue which was described by Ngyen might occur for some reason.

So, go check it out if it is enabled.

1 Like

Hello and Thank you for you two.

To Larsen
I cannot change proxy setting. Even if I change, same setting come back even after Zapp Exit.
I cannot change, but administrator says no such GPO is enabled.
Do you know anything other problem? Is it simply my laptop is broken?

To inamura
Unfortunately, administrator says no such setting .
Do you know anything other?

Best Regards,
Ngyen

Hello Ngyen

I’ve faced the same issue for a short time.
I have no clue what was the trigger. But during I was facing the issue, I found that the cause of this issue. And it might be “Automatically Detect Settings” in Internet Option.
(type “Internet option” on you windows, select “Connections” tab, and click “LAN settings”)

As the expected behavior, if you use TWLP mode, this item must not be checked.
But when i got this issue, this item was automatically checked for some reason.
I also could check and un-check this even though Z-App is ON.

In addition to this, if I use TWLP mode, “Use automatic configuration script” should be filled with loopback PAC file, which looks like http://127.0.0.1:xxxx/localproxy-xxxxxxxx.pac, AUTOMATICALLY, and this must not be editable when Z-App is ON.
But it was not filled even after I turned on Z-App, and I could edit it.

Anyway, when I uncheck the item, the issue was solved.
I do not know why this item was checked by itself. Maybe there should be another fact for that.
But if you are still facing the issue, could you just try to uncheck “Automatically detect settings”? and check if the issue was solved?
This is most likely workaround. I mean, we need to find out if there is another cause of issue.

Regards,
Tokio

1 Like

Hi Ngyen,

Here is a good resource to see all possible settings: https://securelink.net/en-be/insights/windows-proxy-settings-explained/

Somewhere you have proxy settings enabled.

Also, check if you don’t have an “script” running that is forcing proxy settings…or VPN client or Proxy Switcher . Several software are capable to change proxy settings.

Best regards
Adrian

1 Like