ZScaler ZIA and Intune Autopilot

Trying to push ZScaler ZIA via Azure Intune Apps push. Setup everything as it should be but I see it says Install pending and one device it says it failed.

I have specified the
CLOUDNAME=ZSCALERTHREE (which is where we are on the cloud)
USERDOMAIN=OURDOMAIN NAME.COM

Assignments - I have assigned it to the group of people who should get the app

Available for enrolled devices - I have added the device group of Intune in Azure AD

What else would need to be setup in order to get this installed. I have other apps that I am able to push. But this is not getting installed through Autopilot devices. Any suggestions or thoughts please let me know.

Thanks
John

Have you referred to this post?

Yes, that is the one I have used. Sorry it is not intune package. It is Line of business app and used the MSI as it is mentioned here.

Have you looked at the event logs on the machine to see what might have happened during the installation? There are also Intune logs that might help as well. Hard to tell why it’s not installing from just a “failed” message.

Someone just responded that they packaged it for Intune and pushed it and it works, but I will try that and let you know.

Yes please do! This question is asked a few times and I would love to have a definitive path!

Thanks John

I tried packaging and it would not install and it failed. But, if I package it to Intune format I am not able to specify the CLOUDNAME=zscalertwo and USERDOMAIN=XYZ.COM

Not sure where I can specify this while Adding the Intune package. Any suggestions?

I personally haven’t used Intune in a while and haven’t done it with ZCC.

You could try adding /l*v “C:\Windows\temp\App_ZCC.log” to the install string to try and get some logs.

Thanks Ben. Here is my discussion in Reddit

I am testing it now and will keep you all posted if it is successful.

1 Like

Hello John,

we use intune App Deployment for various packages and also since “the beginning” for ZCC (32bit) without any issues. As I can see you try to install the x64 edition. Did you also tried the 32bit edition? There are reports of problems with the x64-msi, see here ZApp 32bit vs 64bit support - #10 by brh.

Also you may (!) need to use the /quiet switch to avoid user interaction.

BR
Manuel

EDIT: To get more insights you can also check the intune MDM client logs at C:\ProgramData\Microsoft\IntuneManagementExtension\Logs. I would recommend to use the Microsoft System Center Tool “CMtrace” for reading that logs - makes things a little easier.

Hi Manuel,

Yes, I tried both 64bit and 32bit with no success. As per Microsoft, I am trying this even though it did not help. I tried to push it through Company Portal, as of on Friday it showed that it was pending download. But, then it shows up in the installed/failed state. But, it is not installed on the computer. I have opened a call with ZScaler and Microsoft and they are unable to figure it out. Let me see what they come back with. Unless, something is blocking the installation of Zscaler then I am not sure how to have this pushed first and the other apps pushed next after Zscaler install.

How to perform a clean boot in Windows (microsoft.com)

What I see is Event ID 11704 which says
Product: Vmware horizon client — Error 11704 An installation of Zscaler is currently suspended. You must undo the changes made by that installation to continue. Do you want to undo those changes?
Similarly with another app

Product: LogMein Client — Error 11704 An installation of Zscaler is currently suspended. You must undo the changes made by that installation to continue. Do you want to undo those changes? Similarly with another app

I just have 3 apps installed prior to ZScaler

  1. VMWare Horizon Client
  2. LogMeIn client
  3. Zoom client

Unless, I do not push all these apps and only have ZScaler installed first and then push the other three. But, that will not work in real environment.

Assign it required to the device, not to the user. The context of the MSI is Device.

For ZCC the app install context is preconfigured within the MSI to “Device”. There is no possibility to set the install context to “User”, at least not for Zscaler Client Connector MSI.

Yes. My note was about the assignment. The Group needs to be filled with Devices, not Users i guess.

Must be something else as assignment via “user groups” (groups containing users and not devices) works flawless here. And group assignment context is also inhereted from app install context.

@oryx360 John, did you check the IME logs? Any hints/errors here?