Zscaler ZIA O365 Apps not authenticating

We have a fairly new setup we are trying to implement. We have it working mostly, but when one of our users had to change their O365 passwords the login box for O365 Apps never loads. It is just a white box. If they log into the OWA the login page works perfectly fine. We have tried adding all the O365 urls to our PAC file or to the SSL bypass. Still no luck.

We have reached out to Zscaler and are waiting to hear back, but our director is eager to push this out to more than just our team.

Here is an image of what we are getting.

I used to encounter same issue while using one older ZCC version. You may try with latest ZCC version.

I have the most recent version of ZIA app installed.

I think we did find a workaround though. By adding microsoft.com to the app profile bypass it allows for it to properly sign in. Afterwards it still prompts the user to sign into zscaler, but we want that anyway. I will update this after a few days of testing to make sure that is our permanent solution.

I did not get it. Have you got the same issue when using Microsoft One Click configuration on Zscaler that should resolve proxy issues for Office 365:

We went through the best practices with an engineer from Zscaler, but they were having issues getting it to work with just the pac file as well.

We have users that we cannot use the ZIA app so we have to use just the pac file. I have this working through the ZIA app now, but with just the pac file we continue to get the white box.

Thank you for all your suggestions so far.

Is there a reason you want to use a pac file and not zcc?

We have it working now with the PAC file. We want to use ZCC, but we have ADFS setup and when trying to login to ZCC on the LAN the wia page does not load properly. We believe its a DNS issue, but we had a deadline to get webfiltering. So instead we used the PAC file until we can push ZCC out.