Enable ZCC crash logs without GUI

One of my customers uses ZScaler Client Connector for remote access.
I installed a new Win 10 system and installed Zscaler Client Connector.
I can dial in, Zscaler is working fine. After a reboot, Zscaler will no longer open up, though. No tray icon.

I believe that the ZScaler Client Connector keeps on crashing. I would like to enable the crash log, but it seems I can only do that from the GUI. But I can’t access the GUI.

Is there any way, maybe through the registry, how I can enable the Zscaler Client Connector crash log?
ZScaler Client Connector 3.6.0.26_V3222

Hi Valentin,

I’m not aware of a way to do this because it’s managed via the App profile.
Normally policy overwrites. Questions:

  1. is this crash happening for everyone or just a few machines ?
  2. The Certutil.exe file needed on allowlists was renamed to ZSFFutil.exe in ZCC 3.6…has allowlists been updated ?

My suggestion, move troubled users to new App Profile that has ZCC debug log level enabled, repro crash and grab the log from “C:\ProgramData\Zscaler” and raise it with Zscaler Support.

G

Hi Gerhard,

thanks for taking the time to write a reply to my question :slight_smile:
I have installed Zscaller on my personal notebook that I use only for this client.
Hence, it is not part of some bigger AD infrastructure and there is no policy from the customer that needs to be enforced on my system.
The support of the customer is not aware of any other contractors having the same issues.
I guess I have to ask the customer to raise a ticket at Zscaler support then.

I just found that reason for ZScaler Client Connector crashing on Windows 10 (kvm/qemu VM with virtio drivers).

Mabye others will find this thread and be happy to read the workaround.

In my case, I have a Win10 VM that is only there for a specific customer. I installed Win10, Zscaler etc. inside this VM. I used RDP to connect to my VM (localhost) to work with my Win10.
It turns out that when I do not use RDP, but VNC or Spice, ZScaler will not crash and remain stable.
As I have found elsewhere in the internet, it might happen that ZScaler can not deal with a RDP session and one has to use a different method to access the system.
As soon as I switched to spice, the ZScaler GUI was stable and I was able to work with ZScaler again.

1 Like