Web Insight hang/not responding filter log

Dear All,

Good day to everyone,

Looking for tips to improve performance of ZIA Web Insight log, I encountered slowness when using Domain filter on Insights, and also not responding at downloading the Logs (Less than 1K record under Advanced Threat filtering).
I have tried with Chrome/Edge browser.
I tried with Unifi ISP, and Celcom mobile data, with the same result.

This decreases my productivity and consumes a lot of my time. Looking forwards to tips to improve this.

Thank you.

Hi @syazwan . This issue is not see with other client tenants. Can you please try with reducing the number of fields while downloading the report.

Hi @bmathur this customer tenant on Zscaler.net, with 40K endpoint installed with ZCC tunnel 2.0.
There is also server traffic sending to Zscaler as well.

Attached screenshot of what the not responding looks like on my end, it has been running more than 10 minute.

Following your tips, I only choose below fields:

  1. No.
  2. User name
  3. URL
  4. SSL Inspection

But, with same result. Log query still hang, which eventually will show up with result some time later. And then, click Download the report button will causing it hang again.

Any other ideas i can try?

can confirm that issue (zscalertwo.net)
depending on which combination of fields one filters for it can take up to well over 30 minutes before the results are shown (and approx the same time again if one then wants to download the results)

In general it seems like ‘the more you dive into the details and/or the more filters you set the slower it gets’. Some filters add just minor delays (eg user), others add a LOT of delay (eg url search).