ZPA connection breaking Miracast screen sharing on Windows laptops

I am unable to wirelessly share/project my screen while ZPA is connected.
I saw a similar problem with AnyConnect, but only on full tunnel connections. With AnyConnect split tunnel, I was able to be connected and do wireless screen sharing at the same time.

Is there a fix available to prevent ZPA from breaking Miracast screen sharing?

Hi Jax,
Can you check in your ZPA logs to see if there are any error messages associated with the domains being used with Miracast? Once you locate those URLs, you can create an app segment and set it to “always bypass” so they are not routed through ZPA.

Warm Regards,

1 Like

Miracast works by directly connecting to other devices on the local wireless network. It doesn’t require internet access.

Still having the issue.
Miracast connects via the local WiFi network and does not go through the internet.
If your internet connection goes down, you can still use Miracast to project local content. It doesn’t have internet access requirements like Google Chromecast or Apple AirPlay.

How can we find out why connecting to ZPA prevents local wireless display from working?

Hi Jack,

When you ping Miracast FQDN, do you get the ZPA synthetic IP (100.64..) ?

I don’t know that there is a “Miracast FQDN” to ping.
It’s all supposed to work seamlessly by using Windows key plus K and then Windows detects wireless displays available on the same network.
Windows can see the wireless displays and starts trying to connect even with ZPA connected, but if ZPA is connected, the screen image never gets mirrored. There is some communication happening because the wireless display shows my device attempting to connect,
After disconnecting from ZPA, the laptop successfully completes the connection and projects the screen to the other device as expected.

You should be able to choose screen mirroring or using the Miracast device as a wirelessly-connected second monitor,.

Hi Jack,

Okay then I agree with Chris, you’ll to look at the ZPA logs.
I’m guessing you are running ZPA in a wildcard discovery hence the Miracast being intercepted by ZCC on the same network. As Chris mentioned once identified what Miracast is using then it can be bypassed in ZPA .Maybe use your favourite TCP viewer to identify the process/port etc.

Sorry cant be of more help Jack

Which ZPA logs are you referring to? Are there local logs in Windows with this information or do you mean backend logs that the ZScaler admin would need to access?

could be that Miracast and ZPA wont work together
At least most articles about ‘Miracast not working’ propose to disable any third-party VPN

It works with split tunnel VPN at least if the wireless display connection is established before starting the VPN.
With ZPA, even if I connect to the wireless display prior to ZPA, the ZPA connection drops the already-established wireless display connection.

did you try to do a wireshark trace (or do a packet capture inside ZCC) in to see what exactly happens?

Easy way for me will be the ZPA admin console using live diagnostic but you could have a look at ‘ZSATunnel.log’ on the client but that wraps very quickly and depends on your viewer.