ZSATray Icon issue client connector

Hello community,

Some of our colleagues experience an annoying / hindering behavior of the ZCC on their Win 10 clients (1909 or 20H2).
In the mid of January we upgraded successfully couple thousand ZCC installations from 1.5.x to 3.1.x . Around 3-4 weeks later, problems on clients started when users connect to their virtual or physical workstations using Citrix.
The ZCC doesn’t start/connect as usual, the ZSATray.exe process starts and gets stopped within the next second. Just a few seconds later that is repeated, again, again and again … On some clients all ZSATray.exe processes disappear after getting stopped, in some cases couple of them remain as stopped.
Each time a ZSATray.exe process tries to start, it generates a new Zscaler tray icon, which will not automatically disappear when the process is stopped / disappearing.

Result: An whole screen full of Zscaler tray icons when you check the hidden tray icons. Usually they are all gray (like disabled/not connect ZCC), rarely there is a lonely “connected” blue icon, but you cannot open ZCC through any of them (neither gray, nor blue), they disappear as soon as you move the mouse over them.
You can clean up all tray icons, but shortly there start to reappear, one by one.
Due to the frequent attempt to restart the process, a ton of logfiles get generated, over 100k files are easily reached.

We already tried the newer version 3.1.0.129 instead of our .103 we currently use, as upgrade installation as well as clean installation. No success.

As soon as you login via RDP (Remote Desktop User group), it works fine, if the colleagues connect again via Citrix, the issue reappears.
After you logged in once with admin permission via RDP, the issue seems to be solved, also when you login later via Citrix is seem to work fine so far.
But that cannot be the solution, granting admin permission generally to all users and hoping it is solved afterwards – logistical nightmare, especially as we currently only from a few workstations that issue is reported, but potentially couple hundreds could be effected!

We checked the location service settings, but that also wasn’t the solution:
Logging in with one user after activating the location service – ZCC works fine. Next day another user works with the same workstation, the issue appears again.
For that user it helped to perform a cold reboot (Windows > Shutdown > Turn on via power button), for another colleague on another workstation it didn’t work.

So far, everything we tried and eventually worked feels like rolling a dice.

We would appreciate if one of you had similar experiences and a working solution for it or an idea / suggestion what we can check or change to fix it properly.

Thanks!

regards